aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-27 11:22:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-27 11:22:20 +0000
commit6c21bcaa65d0b9c38f60a9735de59cf441c3be52 (patch)
tree43d42290c9a785d8290d37b7e61f25b44d0f46a5 /target/imagebuilder/files
parent4d96170c32c8f4ae54d1a632261c13f2b19eed1e (diff)
downloadupstream-6c21bcaa65d0b9c38f60a9735de59cf441c3be52.tar.gz
upstream-6c21bcaa65d0b9c38f60a9735de59cf441c3be52.tar.bz2
upstream-6c21bcaa65d0b9c38f60a9735de59cf441c3be52.zip
IB: use online repositories
Change the IB packaging to only embed libc, kernel and kmod packages by default and generate repositories.conf to refer to the remote package repositories. Introduce a new config option CONFIG_IB_STANDALONE which restores the old behaviour of building self contained IB archives. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45772
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile4
-rw-r--r--target/imagebuilder/files/repositories.conf2
2 files changed, 2 insertions, 4 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index f3bfec1e31..0f0fe42b59 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -107,7 +107,7 @@ _call_image:
$(MAKE) package_index; \
else \
mkdir -p $(TARGET_DIR)/tmp; \
- $(OPKG) update; \
+ $(OPKG) update || true; \
fi
$(MAKE) package_install
ifneq ($(USER_FILES),)
@@ -123,7 +123,7 @@ package_index: FORCE
(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
gzip -9c Packages > Packages.gz \
) >/dev/null 2>/dev/null
- $(OPKG) update
+ $(OPKG) update || true
package_install: FORCE
@echo
diff --git a/target/imagebuilder/files/repositories.conf b/target/imagebuilder/files/repositories.conf
index 708855eb8c..8f1f27fe50 100644
--- a/target/imagebuilder/files/repositories.conf
+++ b/target/imagebuilder/files/repositories.conf
@@ -2,5 +2,3 @@
# src/gz %n %U
# src custom file:///usr/src/openwrt/bin/%T/packages
-## This is the local package repository, do not remove!
-src imagebuilder file:packages