aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-09-15 12:44:36 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-10-30 00:39:09 +0000
commit2999f810ff2c968e6bbe5b2fd32cfbd80f83570a (patch)
tree41452333f2f17af0a58896ffd675cad2b654e6ab /target/imagebuilder/files
parent071514c6419151674d50a4607dc09303f54014ce (diff)
downloadupstream-2999f810ff2c968e6bbe5b2fd32cfbd80f83570a.tar.gz
upstream-2999f810ff2c968e6bbe5b2fd32cfbd80f83570a.tar.bz2
upstream-2999f810ff2c968e6bbe5b2fd32cfbd80f83570a.zip
build,IB: include kmods only in local builds
The buildbots generate a kmod archive which should be used instead of a local copy. This is possible due to the introduction of a kernelversion specific feed. This commit adds the ability of using only signed package feeds. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 27d3cfa8df..03a95dbf6e 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -153,8 +153,8 @@ package_list: FORCE
package_install: FORCE
@echo
@echo Installing packages...
- $(OPKG) install $(firstword $(wildcard $(PACKAGE_DIR)/libc_*.ipk $(PACKAGE_DIR)/base/libc_*.ipk))
- $(OPKG) install $(firstword $(wildcard $(PACKAGE_DIR)/kernel_*.ipk $(PACKAGE_DIR)/base/kernel_*.ipk))
+ $(OPKG) install $(firstword $(wildcard $(LINUX_DIR)/libc_*.ipk $(PACKAGE_DIR)/libc_*.ipk))
+ $(OPKG) install $(firstword $(wildcard $(LINUX_DIR)/kernel_*.ipk $(PACKAGE_DIR)/kernel_*.ipk))
$(OPKG) install $(BUILD_PACKAGES)
prepare_rootfs: FORCE