aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:47 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:47 +0000
commit63cb54edd5e55ad7f89eea303deb34a2e38cf874 (patch)
treeb3367ee4159104d807163e570c66d52f131db791 /target/imagebuilder/files/Makefile
parentae669a075f4c0d41f62fc0d73fa37cea9f64ea10 (diff)
downloadupstream-63cb54edd5e55ad7f89eea303deb34a2e38cf874.tar.gz
upstream-63cb54edd5e55ad7f89eea303deb34a2e38cf874.tar.bz2
upstream-63cb54edd5e55ad7f89eea303deb34a2e38cf874.zip
build: introduce per feed repository support
This changeset implements a new menuconfig option to generate separate repositories for each enabled package feed instead of one monolithic one. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42002 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42016 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder/files/Makefile')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index ecaf5ccda3..222dac43cc 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -126,8 +126,8 @@ package_index: FORCE
package_install: FORCE
@echo
@echo Installing packages...
- $(OPKG) install $(PACKAGE_DIR)/libc_*.ipk
- $(OPKG) install $(PACKAGE_DIR)/kernel_*.ipk
+ $(OPKG) install $(firstword $(wildcard $(PACKAGE_DIR)/libc_*.ipk $(PACKAGE_DIR)/base/libc_*.ipk))
+ $(OPKG) install $(firstword $(wildcard $(PACKAGE_DIR)/kernel_*.ipk $(PACKAGE_DIR)/base/kernel_*.ipk))
$(OPKG) install $(BUILD_PACKAGES)
rm -f $(TARGET_DIR)/usr/lib/opkg/lists/*