aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-02 13:27:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-02 13:27:31 +0000
commit897b2e4b98cc5861c2bf861cba0196c59f8e5200 (patch)
tree8fd0168ff6621f0e6218aa4e0a8db40c3b9926da /target/imagebuilder/Makefile
parentaab9ffeacc558abb1a9cb088fc526868c3f46bb5 (diff)
downloadupstream-897b2e4b98cc5861c2bf861cba0196c59f8e5200.tar.gz
upstream-897b2e4b98cc5861c2bf861cba0196c59f8e5200.tar.bz2
upstream-897b2e4b98cc5861c2bf861cba0196c59f8e5200.zip
target/imagebuilder: add missing package index (fixes #16675)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40968
Diffstat (limited to 'target/imagebuilder/Makefile')
-rw-r--r--target/imagebuilder/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 5dd95eabbd..e52ca623ee 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -50,6 +50,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
| $(XARGS) rm -rf
find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
| $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
+ $(MAKE) -C $(PKG_BUILD_DIR) package_index
$(TAR) c -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
download: