aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-08 00:36:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-08 00:36:35 +0000
commit699876fa6b30be6a3fa11db92bce249d090aeb85 (patch)
treef2b33d2ee119f51b173d4bfc3be71d4fcc116690 /target/imagebuilder/Makefile
parent91118a9500eec1bededcdb8e2f0058368ca7f8b7 (diff)
downloadupstream-699876fa6b30be6a3fa11db92bce249d090aeb85.tar.gz
upstream-699876fa6b30be6a3fa11db92bce249d090aeb85.tar.bz2
upstream-699876fa6b30be6a3fa11db92bce249d090aeb85.zip
- add a helper script to generate opkg.conf, attempt to detect package architecture from packages/ - fix package defaults when no package override is given, IB previously aggregated the defautls of all profiles - introduce a repositories.conf, allows using remote opkg repositories in imagebuilder
SVN-Revision: 22978
Diffstat (limited to 'target/imagebuilder/Makefile')
-rw-r--r--target/imagebuilder/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 42fb7bb69b..9e9afb2b27 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -22,15 +22,18 @@ all: compile
$(BIN_DIR)/$(IB_NAME).tar.bz2: clean
rm -rf $(PKG_BUILD_DIR)
- mkdir -p $(IB_KDIR) $(PKG_BUILD_DIR)/staging_dir/host $(PKG_BUILD_DIR)/target
+ mkdir -p $(IB_KDIR) $(PKG_BUILD_DIR)/staging_dir/host \
+ $(PKG_BUILD_DIR)/target $(PKG_BUILD_DIR)/scripts
-cp $(TOPDIR)/.config $(PKG_BUILD_DIR)/.config
$(CP) \
$(INCLUDE_DIR) $(SCRIPT_DIR) \
$(TOPDIR)/rules.mk \
./files/Makefile \
+ ./files/repositories.conf \
$(TMP_DIR)/.targetinfo \
$(TMP_DIR)/.packageinfo \
$(PKG_BUILD_DIR)/
+ $(CP) ./files/opkg-generate-config.sh $(PKG_BUILD_DIR)/scripts/
$(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
$(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
$(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/