aboutsummaryrefslogtreecommitdiffstats
path: root/target/image/brcm
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-11-01 13:24:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-11-01 13:24:20 +0000
commite7614e91b9a29e7b61cc5d4da4138dfef91a19dd (patch)
treeeb1c0060626c2fe71b5c61932a3a2b3bb0472db8 /target/image/brcm
parentec52fc217de0d0eb81a3a5251b37382bfd606d59 (diff)
downloadupstream-e7614e91b9a29e7b61cc5d4da4138dfef91a19dd.tar.gz
upstream-e7614e91b9a29e7b61cc5d4da4138dfef91a19dd.tar.bz2
upstream-e7614e91b9a29e7b61cc5d4da4138dfef91a19dd.zip
Add USR5461 image generation and tool (#817), thanks to Dick Streefland !
SVN-Revision: 5373
Diffstat (limited to 'target/image/brcm')
-rw-r--r--target/image/brcm/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/image/brcm/Makefile b/target/image/brcm/Makefile
index 2dc599daea..6aad5581e7 100644
--- a/target/image/brcm/Makefile
+++ b/target/image/brcm/Makefile
@@ -37,6 +37,10 @@ define Image/Build/Motorola
$(STAGING_DIR)/bin/motorola-bin -$(3) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx $(BIN_DIR)/openwrt-$(2)-$(4).bin
endef
+define Image/Build/USR
+ $(STAGING_DIR)/bin/trx2usr $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx $(BIN_DIR)/openwrt-$(2)-$(3).bin
+endef
+
define trxalign/jffs2-128k
-a 0x20000
endef
@@ -64,6 +68,7 @@ ifeq ($(KERNEL),2.6)
endif
endif
$(call Image/Build/Motorola,$(1),wr850g,1,$(1))
+ $(call Image/Build/USR,$(1),usr5461,$(1))
endef
$(eval $(call BuildImage))