aboutsummaryrefslogtreecommitdiffstats
path: root/target/image/brcm63xx/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
committerMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
commitc3c4dfb57beebd26c0534698b8687c2c7c94e1f5 (patch)
tree6ffc51e355fb56df1c38449e6c16711d0b27a29c /target/image/brcm63xx/Makefile
parent16edf83d62c8a8bc446b5d9a74de27c2dd4f3d8b (diff)
downloadupstream-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.tar.gz
upstream-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.tar.bz2
upstream-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.zip
move target/image/platform to target/linux/platform/image platform directories are now self contained
SVN-Revision: 5669
Diffstat (limited to 'target/image/brcm63xx/Makefile')
-rw-r--r--target/image/brcm63xx/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/target/image/brcm63xx/Makefile b/target/image/brcm63xx/Makefile
deleted file mode 100644
index 6aa72c2920..0000000000
--- a/target/image/brcm63xx/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-LOADADDR = 0x8108c8f4 # RAM start + 16M
-KERNEL_ENTRY = 0x80100000 # Default kernel entry in arch/mips/Makefile
-RAMSIZE = 0x01000000 # 64MB
-
-LOADER_MAKEOPTS= \
- KDIR=$(KDIR) \
- LOADADDR=$(LOADADDR) \
- KERNEL_ENTRY=$(KERNEL_ENTRY) \
- RAMSIZE=$(RAMSIZE)
-
-define Build/Clean
- $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) clean
-endef
-
-define Image/Prepare
- cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) compile
-endef
-
-define Image/Build
- cp $(KDIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
-endef
-
-$(eval $(call BuildImage))