aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-09 13:21:53 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-09 13:51:35 +0100
commitd826af2cbbc7ff9781d6b9fdde5866f6e6367ec6 (patch)
treeec6a6e8056f87951caf31eb9819fdc9e54b86507 /target/Makefile
parentda0b9110fc783245aaa88ae6ed28aa6d5fe1bdea (diff)
downloadupstream-d826af2cbbc7ff9781d6b9fdde5866f6e6367ec6.tar.gz
upstream-d826af2cbbc7ff9781d6b9fdde5866f6e6367ec6.tar.bz2
upstream-d826af2cbbc7ff9781d6b9fdde5866f6e6367ec6.zip
build: make <subdir>/install opt-in, use it for target/ only
Fixes buildbot errors on running make target/install or toolchain/install Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/Makefile b/target/Makefile
index db87c78aae..7ad26c7177 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -6,6 +6,7 @@
#
curdir:=target
+$(curdir)/subtargets:=install
$(curdir)/builddirs:=linux sdk imagebuilder toolchain
$(curdir)/builddirs-default:=linux
$(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),imagebuilder) $(if $(CONFIG_MAKE_TOOLCHAIN),toolchain)