aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-11-04 16:12:51 +0100
committerJo-Philipp Wich <jo@mein.io>2016-11-04 16:14:51 +0100
commit5a37d0601a5431e5c6c721d1ed39a80568b54679 (patch)
tree03e8aaf2cfe3a14b3d2c4ed6019e642718036b75 /target/Makefile
parent17ecd879b81cce6311009957ec9650baebd82ec7 (diff)
downloadupstream-5a37d0601a5431e5c6c721d1ed39a80568b54679.tar.gz
upstream-5a37d0601a5431e5c6c721d1ed39a80568b54679.tar.bz2
upstream-5a37d0601a5431e5c6c721d1ed39a80568b54679.zip
sdk: depend on linux/install
Since commit 484cb91 "sdk: bundle required firmware files" there is an implicit dependency of the SDK on a prior Kernel compilation. Change target/Makefile to make this dependency explicit to avoid race conditions with parallel builds. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/Makefile b/target/Makefile
index cb68454c91..db87c78aae 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -10,6 +10,7 @@ $(curdir)/builddirs:=linux sdk imagebuilder toolchain
$(curdir)/builddirs-default:=linux
$(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),imagebuilder) $(if $(CONFIG_MAKE_TOOLCHAIN),toolchain)
+$(curdir)/sdk/install:=$(curdir)/linux/install
$(curdir)/imagebuilder/install:=$(curdir)/linux/install
$(eval $(call stampfile,$(curdir),target,prereq,.config))