aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-06 17:24:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-06 17:24:05 +0000
commit072bed476076acec560557e985ca0ddcdd62be9a (patch)
tree244a3a7b1ec6637f661b18cb4f02b30d412d8d1d /target/Makefile
parent02ab0d3ef9aec76683be52f7b32bff3f6c1aeadf (diff)
downloadupstream-072bed476076acec560557e985ca0ddcdd62be9a.tar.gz
upstream-072bed476076acec560557e985ca0ddcdd62be9a.tar.bz2
upstream-072bed476076acec560557e985ca0ddcdd62be9a.zip
target: do not make target/*/install depend on target/*/compile - removes one redundant kernel build dir call on target/install
SVN-Revision: 32091
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/Makefile b/target/Makefile
index 81ec60234a..cb68454c91 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -10,10 +10,7 @@ $(curdir)/builddirs:=linux sdk imagebuilder toolchain
$(curdir)/builddirs-default:=linux
$(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),imagebuilder) $(if $(CONFIG_MAKE_TOOLCHAIN),toolchain)
-$(curdir)/imagebuilder/compile:=$(curdir)/linux/install
-
-# prerequisites for the individual targets
-$(curdir)//install = $(1)/compile
+$(curdir)/imagebuilder/install:=$(curdir)/linux/install
$(eval $(call stampfile,$(curdir),target,prereq,.config))
$(eval $(call stampfile,$(curdir),target,compile,$(TMP_DIR)/.build))