aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-02 15:51:39 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-02 15:51:39 +0200
commitb99623329c07712c30b5ad2e0f3b3dffe3ed97c2 (patch)
tree80b07ae771b73b28b7c2096be404dbecdce65ccf /scripts
parentd0113711a31f00c9c95c33e8a5e290425b63bde6 (diff)
downloadupstream-b99623329c07712c30b5ad2e0f3b3dffe3ed97c2.tar.gz
upstream-b99623329c07712c30b5ad2e0f3b3dffe3ed97c2.tar.bz2
upstream-b99623329c07712c30b5ad2e0f3b3dffe3ed97c2.zip
scripts/checkpatch.pl: fix README.md file name after rename
checkpatch.pl uses a list of files to detect the root OpenWrt directory. This includes README, which has been renamed to README.md in the previous commit. Update the file name in checkpatch.pl to prevent errors like the following when running the script: Must be run from the top-level dir. of a OpenWrt tree Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/checkpatch.pl2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 5224ea49c3..24793e19d8 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -391,7 +391,7 @@ sub top_of_openwrt_tree {
my ($root) = @_;
my @tree_check = (
- "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README",
+ "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
"feeds.conf.default", "include", "package", "rules.mk",
"scripts", "target", "toolchain", "tools"
);