aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-03-24 18:54:36 -1000
committerPaul Spooren <mail@aparcar.org>2021-03-24 19:03:24 -1000
commitb36068d35d9edbd8ed6aaeed6f4c863bfe4cfbee (patch)
treee0668e39947a962a241df8992e19bd1ae2ad080f /scripts
parent8c8496435a9d6a89eeb1b91b9d600362a0b24b16 (diff)
downloadupstream-b36068d35d9edbd8ed6aaeed6f4c863bfe4cfbee.tar.gz
upstream-b36068d35d9edbd8ed6aaeed6f4c863bfe4cfbee.tar.bz2
upstream-b36068d35d9edbd8ed6aaeed6f4c863bfe4cfbee.zip
build,json: fixup fixup of arch_packages
The commit "1bf2b3fe90 build,json: fixup missing arch_packages" fixes the missing package architecture locally but runs $(TOPDIR)/Makefile rather than a target specific one. While this works on local builds just fine, it causes the buildbots to add garbage to the `arch_packages` variable: cd \"/builder/shared-workdir/build\"; git log --format=%h -1 toolchain > /builder/shared-workdir/build/tmp/.ver_check\ncmp -s /builder/shared-workdir/build/tmp/.ver_check /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl/stamp/.ver_check || { \\\n\trm -rf /builder/shared-workdir/build/build_dir/target-x86_64_musl /builder/shared-workdir/build/staging_dir/target-x86_64_musl /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl /builder/shared-workdir/build/build_dir/toolchain-x86_64_gcc-8.4.0_musl; \\\n\tmkdir -p /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl/stamp; \\\n\tmv /builder/shared-workdir/build/tmp/.ver_check /builder/shared-workdir/build/staging_dir/toolchain-x86_64_gcc-8.4.0_musl/stamp/.ver_check; \\\n}\nx86_64 Only the last line contains the desired string. Future investigation should check why the build system prints this to stdout rather than stderr. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/json_overview_image_info.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/json_overview_image_info.py b/scripts/json_overview_image_info.py
index e0e1ff08d5..cd814a19c0 100755
--- a/scripts/json_overview_image_info.py
+++ b/scripts/json_overview_image_info.py
@@ -53,6 +53,8 @@ if output:
[
"make",
"--no-print-directory",
+ "-C",
+ "target/linux/{}".format(output["target"].split("/")[0]),
"val.ARCH_PACKAGES",
],
stdout=PIPE,