aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-03-20 23:23:34 -1000
committerPaul Spooren <mail@aparcar.org>2021-03-20 23:58:52 -1000
commit7f4c2b1a4f9216218dced64794318f2197565c85 (patch)
treec4f9e851539a3821b1fe4679d8796e343da66c1f /scripts
parent2ba0ab1930bd0f28404835b4393a6c99bcd0196c (diff)
downloadupstream-7f4c2b1a4f9216218dced64794318f2197565c85.tar.gz
upstream-7f4c2b1a4f9216218dced64794318f2197565c85.tar.bz2
upstream-7f4c2b1a4f9216218dced64794318f2197565c85.zip
build,json: fix duplicates in default_packages
Calling without the DUMP=1 argument causes the target specific Makefile to be "included" again which adds the target specific packages twice, once on the actual run and once included from `include/target.mk`. This led to duplicate package entries, causing confusion in downstream projects using the generated JSON files. While at it, apply `black` style to Python script. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/json_overview_image_info.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/json_overview_image_info.py b/scripts/json_overview_image_info.py
index ca6fbbc962..23d8dcb857 100755
--- a/scripts/json_overview_image_info.py
+++ b/scripts/json_overview_image_info.py
@@ -38,9 +38,10 @@ if output:
"make",
"--no-print-directory",
"-C",
- "target/linux/{}".format(output['target'].split('/')[0]),
+ "target/linux/{}".format(output["target"].split("/")[0]),
"val.DEFAULT_PACKAGES",
"val.ARCH_PACKAGES",
+ "DUMP=1",
],
stdout=PIPE,
stderr=PIPE,