aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-09-22 09:08:58 -1000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-14 19:21:38 +0100
commit6d5425976f562000ea319180e6c329886bba2c1f (patch)
tree449973baa369aa26de112e655c2af91623b173ff /scripts
parent882e3014610be8ec9a2feb63b544b917c39b8293 (diff)
downloadupstream-6d5425976f562000ea319180e6c329886bba2c1f.tar.gz
upstream-6d5425976f562000ea319180e6c329886bba2c1f.tar.bz2
upstream-6d5425976f562000ea319180e6c329886bba2c1f.zip
scripts: fix checkpatch.pl for changed license dir
As multiple LICENSES are shipped and no longer just LICENSE, modify the OpenWrt tree detection in checkpatch.pl. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/checkpatch.pl2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 8ffc093548..81b1ffcb56 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -1113,7 +1113,7 @@ sub top_of_openwrt_tree {
my ($root) = @_;
my @tree_check = (
- "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
+ "BSDmakefile", "Config.in", "LICENSES", "Makefile", "README.md",
"feeds.conf.default", "include", "package", "rules.mk",
"scripts", "target", "toolchain", "tools"
);