aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-20 00:10:59 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-03-21 10:36:00 +0000
commit2cb6d471b751060144033da8e9e2cdeaa41e0423 (patch)
tree7332b47c2c567fdd873f9ba65e4af84a91c84e0e /scripts
parent30a24882900d41a04eec4db5e3cdbe4026d32aeb (diff)
downloadupstream-2cb6d471b751060144033da8e9e2cdeaa41e0423.tar.gz
upstream-2cb6d471b751060144033da8e9e2cdeaa41e0423.tar.bz2
upstream-2cb6d471b751060144033da8e9e2cdeaa41e0423.zip
scripts: fixup qemustart for new x86 image names
qemustart allows easy testing of created images via `qemu`. The script automatically selects created images and can setup e.g. networks. As the x86 target now uses the generic image.mk the profile appears also in the image name, this is *generic*. Add the profile name to the qemustart script so it still finds the file. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/qemustart2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/qemustart b/scripts/qemustart
index dbb8deddaf..9ce03901aa 100755
--- a/scripts/qemustart
+++ b/scripts/qemustart
@@ -255,7 +255,7 @@ start_qemu_x86() {
local mach="${o_mach:-pc}"
[ -n "$rootfs" ] || {
- rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-combined-ext4.img"
+ rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-generic-ext4-combined.img"
if [ ! -f "$rootfs" -a -s "$rootfs.gz" ]; then
gunzip "$rootfs.gz"
fi