aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/package-metadata.pl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-07-27 00:18:12 +0200
committerJo-Philipp Wich <jo@mein.io>2017-07-27 00:37:05 +0200
commitbf5d32af2a675f7577b388b5eef2a11e6ce042eb (patch)
tree2d27374e6840b775eeaf9718619ad2a84867c675 /scripts/package-metadata.pl
parent9551d91b1d6ac337c3e63870f723cd2a062a5db0 (diff)
downloadupstream-bf5d32af2a675f7577b388b5eef2a11e6ce042eb.tar.gz
upstream-bf5d32af2a675f7577b388b5eef2a11e6ce042eb.tar.bz2
upstream-bf5d32af2a675f7577b388b5eef2a11e6ce042eb.zip
scripts/package-metadata.pl: inhibit compile deps on missing build types
When a package declares a PKG_BUILD_DEPENDENCY or HOST_BUILD_DEPENDENCY on a not existing build type, the metadata script will emit a reference to an unresolvable build target in tmp/.packagedeps, causing the make process to fail hard in a way not catchable by the IGNORE_ERRORS mechanism. In a situation where a package "test-a" declares a build dependency "PKG_BUILD_DEPENDS:=test-b/host" while the Makefile of "test-b" does not implement a HostBuild, make fails with an unrecoverable error in the form: make[1]: Entering directory '...' make[1]: *** No rule to make target 'package/test-b/host/compile', needed by 'package/test-a/compile'. Stop. make[1]: Leaving directory '...' .../toplevel.mk:200: recipe for target 'package/test-a/compile' failed make: *** [package/test-a/compile] Error 2 Extend the metadata generation script to catch such unresolved references and emit a visable warning upon detection. After this change, the script will emit a warning similar to: WARNING: Makefile "package/test-a/Makefile" has a build dependency on "test-b/host" but "package/test-b/Makefile" does not implement a "host" build type Fixes a global build cluster outage which occured after the "python-cffi" feed package removed its HostBuild which the "python-cryptography" package build-depended on. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'scripts/package-metadata.pl')
-rwxr-xr-xscripts/package-metadata.pl31
1 files changed, 25 insertions, 6 deletions
diff --git a/scripts/package-metadata.pl b/scripts/package-metadata.pl
index d4100c1726..261490b868 100755
--- a/scripts/package-metadata.pl
+++ b/scripts/package-metadata.pl
@@ -460,20 +460,27 @@ sub gen_package_mk() {
next unless $pkg->{"builddepends/$type"};
foreach my $dep (@{$pkg->{"builddepends/$type"}}) {
my $suffix = "";
+ my $deptype = "";
my $condition;
if ($dep =~ /^(.+):(.+)/) {
$condition = $1;
$dep = $2;
}
- if ($dep =~ /^(.+)(\/.+)/) {
+ if ($dep =~ /^(.+)\/(.+)/) {
$dep = $1;
- $suffix = $2;
+ $deptype = $2;
+ $suffix = "/$2";
}
my $idx = "";
my $pkg_dep = $package{$dep};
if (defined($pkg_dep) && defined($pkg_dep->{src})) {
+ unless (!$deptype || grep { $_ eq $deptype } @{$pkg_dep->{buildtypes}}) {
+ warn sprintf "WARNING: Makefile '%s' has a %s build dependency on '%s/%s' but '%s' does not implement a '%s' build type\n",
+ $pkg->{makefile}, $type, $pkg_dep->{src}, $deptype, $pkg_dep->{makefile}, $deptype;
+ next;
+ }
$idx = $pkg_dep->{subdir}.$pkg_dep->{src};
} elsif (defined($srcpackage{$dep})) {
$idx = $subdir{$dep}.$dep;
@@ -499,14 +506,16 @@ sub gen_package_mk() {
my $condition;
my $prefix = "";
my $suffix = "";
+ my $deptype = "";
if ($deps =~ /^(.+):(.+)/) {
$condition = $1;
$deps = $2;
}
- if ($deps =~ /^(.+)(\/.+)/) {
+ if ($deps =~ /^(.+)\/(.+)/) {
$deps = $1;
- $suffix = $2;
+ $deptype = $2;
+ $suffix = "/$2";
}
my $pkg_dep = $package{$deps};
@@ -521,7 +530,17 @@ sub gen_package_mk() {
foreach my $dep (@deps) {
$pkg_dep = $package{$deps};
if (defined $pkg_dep->{src}) {
- ($pkg->{src} ne $pkg_dep->{src}.$suffix) and $idx = $pkg_dep->{subdir}.$pkg_dep->{src};
+ unless (!$deptype || grep { $_ eq $deptype } @{$pkg_dep->{buildtypes}}) {
+ warn sprintf "WARNING: Makefile '%s' has a build dependency on '%s/%s' but '%s' does not implement a '%s' build type\n",
+ $pkg->{makefile}, $pkg_dep->{src}, $deptype, $pkg_dep->{makefile}, $deptype;
+ next;
+ }
+ unless ($pkg->{src} ne $pkg_dep->{sec}.$suffix) {
+ warn sprintf "WARNING: Makefile '%s' has a build dependency on itself\n",
+ $pkg->{makefile};
+ next;
+ }
+ $idx = $pkg_dep->{subdir}.$pkg_dep->{src};
} elsif (defined($srcpackage{$dep})) {
$idx = $subdir{$dep}.$dep;
}
@@ -573,7 +592,7 @@ ifndef DUMP_TARGET_DB
( \\
$cmds \\
) > \$@
-
+
ifneq (\$(IMAGEOPT)\$(CONFIG_IMAGEOPT),)
package/preconfig: \$(TARGET_DIR)/etc/uci-defaults/$preconfig
endif