aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/feeds
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-10 00:00:01 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-12 21:18:41 +0200
commit16035a7dd370671670693af9ae63368ee4dd731f (patch)
tree020a3f5bfb365feb0bd566712b85174387e7d509 /scripts/feeds
parent6dac434c0011524b9ac01725727faa1a19ea4a48 (diff)
downloadupstream-16035a7dd370671670693af9ae63368ee4dd731f.tar.gz
upstream-16035a7dd370671670693af9ae63368ee4dd731f.tar.bz2
upstream-16035a7dd370671670693af9ae63368ee4dd731f.zip
include/feeds.mk: rework generation of opkg distfeeds.conf
Allow enabling/commenting/disabling each feed individually by using a tristate config symbol. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'scripts/feeds')
-rwxr-xr-xscripts/feeds5
1 files changed, 3 insertions, 2 deletions
diff --git a/scripts/feeds b/scripts/feeds
index b29e1d5c35..304ef6cbaf 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -824,11 +824,12 @@ sub feed_config() {
my $installed = (-f "feeds/$feed->[1].index");
printf "\tconfig FEED_%s\n", $feed->[1];
- printf "\t\tbool \"Enable feed %s\"\n", $feed->[1];
+ printf "\t\ttristate \"Enable feed %s\"\n", $feed->[1];
printf "\t\tdepends on PER_FEED_REPO\n";
printf "\t\tdefault y\n" if $installed;
printf "\t\thelp\n";
- printf "\t\t Enable the \\\"%s\\\" feed at %s.\n", $feed->[1], $feed->[2][0];
+ printf "\t\t Enable the \\\"%s\\\" feed in opkg distfeeds.conf.\n", $feed->[1];
+ printf "\t\t Say M to add the feed commented out.\n";
printf "\n";
}