aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/config/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-04-20 21:00:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-04-20 21:00:14 +0000
commit320b38dc4fd903d1668b448276059041fa6c8af3 (patch)
treed80f67a6d4781eb99fb309187a799bdffff119dd /scripts/config/Makefile
parent8cc7b94ab02545a6ba6ec042df6e6821941d0e93 (diff)
downloadupstream-320b38dc4fd903d1668b448276059041fa6c8af3.tar.gz
upstream-320b38dc4fd903d1668b448276059041fa6c8af3.tar.bz2
upstream-320b38dc4fd903d1668b448276059041fa6c8af3.zip
modify the kconfig system for openwrt
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3683 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'scripts/config/Makefile')
-rw-r--r--scripts/config/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index 04e8330a01..a731a40e7c 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -1,5 +1,5 @@
# ===========================================================================
-# Kernel configuration targets
+# OpenWrt configuration targets
# These targets are used from top-level makefile
# ===========================================================================
@@ -40,10 +40,10 @@ lex.zconf.c: zconf.l
zconf.hash.c: zconf.gperf
%.tab.c: %.y
- bison -l -b $* -p $(notdir $*) $< && cp $@ $@_shipped || cp $@_shipped $@
+ cp $@_shipped $@ || bison -l -b $* -p $(notdir $*) $<
lex.%.c: %.l
- flex -L -P$(notdir $*) -o$@ $< && cp $@ $@_shipped || cp $@_shipped $@
+ cp $@_shipped $@ || flex -L -P$(notdir $*) -o$@ $<
%.hash.c: %.gperf
- gperf < $< > $@ && cp $@ $@_shipped || cp $@_shipped $@
+ cp $@_shipped $@ || gperf < $< > $@