aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2018-01-24 12:56:39 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-26 12:55:14 +0100
commitcfdfa6d04e16b001e45054dafbf5df3cfc98ef03 (patch)
treec11ea82a5a756190b050d91e637b80b9b27358b0 /rules.mk
parent2c50af0cea14edad1b84725af273fdb1160a3b9f (diff)
downloadupstream-cfdfa6d04e16b001e45054dafbf5df3cfc98ef03.tar.gz
upstream-cfdfa6d04e16b001e45054dafbf5df3cfc98ef03.tar.bz2
upstream-cfdfa6d04e16b001e45054dafbf5df3cfc98ef03.zip
rules.mk: drop `include_mk` build rule
The only users of this were the python packages from the `packages` feed. The 2 python interpreters would export some mk files (e.g. python-package.mk) and then other python packages would include it via this rule. But there's a few things wrong with this approach, most of them drawing from the fact that python host needs to be built first, to export these mk files. By now all uses of include_mk have been corrected in the feeds and this can be removed. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk4
1 files changed, 0 insertions, 4 deletions
diff --git a/rules.mk b/rules.mk
index 9d8b9f8f90..84e0aaadc6 100644
--- a/rules.mk
+++ b/rules.mk
@@ -355,10 +355,6 @@ define shexport
export $(call shvar,$(1))=$$(call $(1))
endef
-define include_mk
-$(eval -include $(if $(DUMP),,$(STAGING_DIR)/mk/$(strip $(1))))
-endef
-
# Execute commands under flock
# $(1) => The shell expression.
# $(2) => The lock name. If not given, the global lock will be used.