diff options
author | Nicolas Thill <nico@openwrt.org> | 2009-07-07 02:34:58 +0000 |
---|---|---|
committer | Nicolas Thill <nico@openwrt.org> | 2009-07-07 02:34:58 +0000 |
commit | c5548f922eec11cd9d1cd323092bc5a44f366268 (patch) | |
tree | 0a58ff22218d8e162d29c02d73fd2aac89d28844 /rules.mk | |
parent | 9c174d95bbbf43c2db088f3a8edbe25b4cfd41ef (diff) | |
download | upstream-c5548f922eec11cd9d1cd323092bc5a44f366268.tar.gz upstream-c5548f922eec11cd9d1cd323092bc5a44f366268.tar.bz2 upstream-c5548f922eec11cd9d1cd323092bc5a44f366268.zip |
add a config option to select the binary stripping method to use (between none, strip & sstrip)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16728 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 9 |
1 files changed, 8 insertions, 1 deletions
@@ -104,7 +104,6 @@ HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib TARGET_CC:=$(TARGET_CROSS)gcc TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no) -STRIP:=$(STAGING_DIR_HOST)/bin/sstrip PATCH:=$(SCRIPT_DIR)/patch-kernel.sh SED:=$(STAGING_DIR_HOST)/bin/sed -i -e CP:=cp -fpR @@ -137,7 +136,15 @@ TARGET_CONFIGURE_OPTS:= \ # strip an entire directory ifneq ($(CONFIG_NO_STRIP),) RSTRIP:=: + STRIP:=: else + ifneq ($(CONFIG_USE_STRIP),) + STRIP:=$(TARGET_CROSS)strip + else + ifneq ($(CONFIG_USE_SSTRIP),) + STRIP:=$(STAGING_DIR_HOST)/bin/sstrip + endif + endif RSTRIP:= \ NM="$(TARGET_CROSS)nm" \ STRIP="$(STRIP)" \ |