aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2020-08-07 11:12:59 -1000
committerFelix Fietkau <nbd@nbd.name>2020-08-10 10:09:55 +0200
commit9e7ef460652748395c897468af662df6ce2cb8d5 (patch)
tree7f878035d51375abf0476b7c4caca5b68e1a861b /rules.mk
parente27fbae63c3436ce5588ca06b78ea88c7a316fee (diff)
downloadupstream-9e7ef460652748395c897468af662df6ce2cb8d5.tar.gz
upstream-9e7ef460652748395c897468af662df6ce2cb8d5.tar.bz2
upstream-9e7ef460652748395c897468af662df6ce2cb8d5.zip
tools: add fakeroot
SELinux support requires setting the appropriate SELinux security context to files and directories, which needs to happen at build time in order to support read-only root filesystem scenarios. In order to create these security contexts, we will have to run some SELinux-specific tools on the host machine, but that requires root access. This adds support for fakeroot, which the build process will use to run the SELinux security context creation and the image creation. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Apply to current master, and adjust commit message Thomas' original work is available at http://lists.infradead.org/pipermail/openwrt-devel/2019-November/025976.html. Signed-off-by: W. Michael Petullo <mike@flyn.org> [add rules.mk FAKEROOT variable] Signed-off-by: Paul Spooren <mail@aparcar.org> [update, fix macos build] Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 479172de03..45d96d6be4 100644
--- a/rules.mk
+++ b/rules.mk
@@ -264,6 +264,7 @@ endif
BUILD_KEY=$(TOPDIR)/key-build
+FAKEROOT:=$(STAGING_DIR_HOST)/bin/fakeroot
TARGET_CC:=$(TARGET_CROSS)gcc
TARGET_CXX:=$(TARGET_CROSS)g++
KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh