diff options
author | Felix Fietkau <nbd@openwrt.org> | 2009-03-03 14:55:53 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2009-03-03 14:55:53 +0000 |
commit | 937f1820f2936d3940240b1cb77b094fd4086df9 (patch) | |
tree | cb5eba0e4f6e22e81665e3ef321d102d1ca321fc /rules.mk | |
parent | a01125e51b4c7e66db0fc72bf8d10698e4f536c6 (diff) | |
download | upstream-937f1820f2936d3940240b1cb77b094fd4086df9.tar.gz upstream-937f1820f2936d3940240b1cb77b094fd4086df9.tar.bz2 upstream-937f1820f2936d3940240b1cb77b094fd4086df9.zip |
replace a few unnecessary $(shell) calls
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 8 |
1 files changed, 3 insertions, 5 deletions
@@ -19,9 +19,7 @@ TMP_DIR:=$(TOPDIR)/tmp export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' -- -define qstrip -$(strip $(subst ",,$(1))) -endef +qstrip=$(strip $(subst ",,$(1))) #")) empty:= @@ -31,7 +29,7 @@ confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n))) strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1)) _SINGLE=export MAKEFLAGS=$(space); -ARCH:=$(call qstrip,$(shell echo $(CONFIG_ARCH) | sed -e 's/i[3-9]86/i386/')) +ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH))))) BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD)) TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION)) TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX)) @@ -41,7 +39,7 @@ LIBC:=$(call qstrip,$(CONFIG_LIBC)) LIBCV:=$(call qstrip,$(CONFIG_LIBC_VERSION)) SUBDIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR}) -OPTIMIZE_FOR_CPU=$(shell echo $(ARCH) | sed -e 's/i386/i486/') +OPTIMIZE_FOR_CPU=$(subst i386,i486,$(ARCH)) ifeq ($(ARCH),powerpc) FPIC:=-fPIC |