aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-14 15:36:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:25 +0100
commit7a315b0b5d6aa91695853a8647383876e4b49a7a (patch)
treeca99d91b9ec9408e37d30f2983847fc5a500d4a7 /rules.mk
parent720b99215da295a2e7b4acdef30b58bec6acedc2 (diff)
downloadupstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.gz
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.bz2
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.zip
build: implement make check and make package/X/check
This is intended to be used for a wide array of package sanity checks. The first check that is implemented is for the hash of downloaded files. It checks: - Missing hash - Use of SHA256 instead of MD5 - dl/<file> hash not matching hash in makefile - deprecated MD5SUM variable The deprecated MD5SUM variable check is skipped for feeds/ until OpenWrt is updated as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index d455f0d960..41e0ef2343 100644
--- a/rules.mk
+++ b/rules.mk
@@ -15,6 +15,11 @@ endif
include $(TOPDIR)/include/debug.mk
include $(TOPDIR)/include/verbose.mk
+ifneq ($(filter check,$(MAKECMDGOALS)),)
+CHECK:=1
+DUMP:=1
+endif
+
export TMP_DIR:=$(TOPDIR)/tmp
qstrip=$(strip $(subst ",,$(1)))
@@ -386,6 +391,9 @@ all:
FORCE: ;
.PHONY: FORCE
+check: FORCE
+ @true
+
val.%:
@$(if $(filter undefined,$(origin $*)),\
echo "$* undefined" >&2, \