aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-06-27 18:51:25 +0200
committerJo-Philipp Wich <jo@mein.io>2018-06-27 18:54:09 +0200
commit681e825f8fbf59a32c3b09810b2a3fef29880c63 (patch)
treec82d2b994edd8ef22f61e59ab22c87dd6919ea63 /rules.mk
parent6e3c2d757a5745dee5cce0b53175b56ad3621d73 (diff)
downloadupstream-681e825f8fbf59a32c3b09810b2a3fef29880c63.tar.gz
upstream-681e825f8fbf59a32c3b09810b2a3fef29880c63.tar.bz2
upstream-681e825f8fbf59a32c3b09810b2a3fef29880c63.zip
build: include package directory in sha256sums when running on buildbot
In order to be able to better compare files to sync in the future, include all BIN_DIR subdirectories in the checksum calculation. To not break existing applications, restrict the recursive checksumming to CONFIG_BUILDBOT for now. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index a97b2d2155..b1ecc24fab 100644
--- a/rules.mk
+++ b/rules.mk
@@ -390,8 +390,9 @@ endef
# Calculate sha256sum of any plain file within a given directory
# $(1) => Input directory
+# $(2) => If set, recurse into subdirectories
define sha256sums
- (cd $(1); find . -maxdepth 1 -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
+ (cd $(1); find . $(if $(2),,-maxdepth 1) -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
xargs -r $(STAGING_DIR_HOST)/bin/mkhash -n sha256 | sed -ne 's!^\(.*\) \(.*\)$$!\1 *\2!p' > sha256sums)
endef