aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-02-24 12:16:33 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-02-27 23:46:53 +0100
commit5ef0854b1109ba2dbd1dd3d9f87ce5801002d0ba (patch)
treed49621928529ec854f2907e1cf43f343c9f14c55 /rules.mk
parentd49ddcdfd27ba3d171b856f223712b88d5fc2046 (diff)
downloadupstream-5ef0854b1109ba2dbd1dd3d9f87ce5801002d0ba.tar.gz
upstream-5ef0854b1109ba2dbd1dd3d9f87ce5801002d0ba.tar.bz2
upstream-5ef0854b1109ba2dbd1dd3d9f87ce5801002d0ba.zip
rules.mk: make PKG_CONFIG_DEPENDS properly track string values
The confvar macro is adjusted to not only consider if a variable has a value or not, but also the value itself. Instead of creating a string of 'y' and 'n' characters, all variable names and values are concatenated and hashed. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index a3fe50b1dc..ed796a5402 100644
--- a/rules.mk
+++ b/rules.mk
@@ -29,7 +29,7 @@ empty:=
space:= $(empty) $(empty)
comma:=,
merge=$(subst $(space),,$(1))
-confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
+confvar=$(shell echo '$(foreach v,$(1),$(v)=$(subst ','\'',$($(v))))' | $(STAGING_DIR_HOST)/bin/mkhash md5)
strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
paren_left = (