aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-01-14 20:04:38 -0800
committerFlorian Fainelli <f.fainelli@gmail.com>2017-01-29 11:51:02 -0800
commit57657a72376000b5843367e627098f09fe9c3647 (patch)
tree15f2b577272e643cecc08485fd8f6bfeae99f710 /rules.mk
parent74ea99b01d936d7b71ee8d0cd0f7c89617b90314 (diff)
downloadupstream-57657a72376000b5843367e627098f09fe9c3647.tar.gz
upstream-57657a72376000b5843367e627098f09fe9c3647.tar.bz2
upstream-57657a72376000b5843367e627098f09fe9c3647.zip
build: Suffix build directory with _$(LIBC) for external toolchains
For external toolchain, we also know the type of C library used, and the toolchain triplet may not always be reflective of that, therefore make $(TARGET_DIR_NAME) suffixed with _$(LIBC). Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 0bd8fde244..f2b53d97a5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -134,7 +134,8 @@ else
GNU_TARGET_NAME=$(shell gcc -dumpmachine)
endif
REAL_GNU_TARGET_NAME=$(GNU_TARGET_NAME)
- TARGET_DIR_NAME:=target-$(GNU_TARGET_NAME)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
+ LIBC:=$(call qstrip,$(CONFIG_LIBC))
+ TARGET_DIR_NAME:=target-$(GNU_TARGET_NAME)_$(LIBC)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
TOOLCHAIN_DIR_NAME:=toolchain-$(GNU_TARGET_NAME)
endif