aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-27 22:50:32 +0100
committerPetr Štetiar <ynezz@true.cz>2020-11-28 16:17:58 +0100
commit524fb5646eec6147aadfdd508219f39bcf8ba8fc (patch)
tree6b73c2c2040cfb72d81cce312a67e4c92ce33958 /rules.mk
parentc7778acf10c9b7c180903d78ea122c2924eae299 (diff)
downloadupstream-524fb5646eec6147aadfdd508219f39bcf8ba8fc.tar.gz
upstream-524fb5646eec6147aadfdd508219f39bcf8ba8fc.tar.bz2
upstream-524fb5646eec6147aadfdd508219f39bcf8ba8fc.zip
cmake.mk,rules.mk: fix host builds using CMake and ccache
Commit f98878e4c17d ("cmake.mk: set C/CXX compiler for host builds as well") has introduced regression as it didn't taken usage of ccache into the account so fix it by handling ccache use cases as well. In order to get this working we need to export HOSTCXX_NOCACHE in rules.mk as well. Fixes: f98878e4c17d ("cmake.mk: set C/CXX compiler for host builds as well") Reported-by: Ansuel Smith <ansuelsmth@gmail.com> Tested-by: Ansuel Smith <ansuelsmth@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index adb103d81f..34222a3a71 100644
--- a/rules.mk
+++ b/rules.mk
@@ -292,6 +292,7 @@ HOSTCXX_NOCACHE:=$(HOSTCXX)
export TARGET_CC_NOCACHE
export TARGET_CXX_NOCACHE
export HOSTCC_NOCACHE
+export HOSTCXX_NOCACHE
ifneq ($(CONFIG_CCACHE),)
TARGET_CC:= ccache_cc