aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-11-25 21:28:17 +0000
committerPaul Spooren <mail@aparcar.org>2020-11-26 12:44:25 -1000
commit3f567d8452644dc5349addabbb8f0bff9d0bc2c0 (patch)
tree2c79a050bbe2089e699c61f4bef093b522ed7ae2 /rules.mk
parent6429307a3d6ba4c88d477cc7a3995be314e3dd15 (diff)
downloadupstream-3f567d8452644dc5349addabbb8f0bff9d0bc2c0.tar.gz
upstream-3f567d8452644dc5349addabbb8f0bff9d0bc2c0.tar.bz2
upstream-3f567d8452644dc5349addabbb8f0bff9d0bc2c0.zip
tools/sstrip: update to latest version
Drop our local sstrip copy and use the current ELFKickers upstream version. Patch the original makefile in order to avoid building elftoc, since it fails with musl's elf.h. This is fine, since we only need sstrip anyway. Finally, add the possibility to pass additional arguments to sstrip and pass -z (remove trailing zeros) by default, which matches the behaviour of the previous version. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> [shorten long commit msg lines] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 3214395e1f..671c8bdad8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -328,7 +328,7 @@ else
STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS))
else
ifneq ($(CONFIG_USE_SSTRIP),)
- STRIP:=$(STAGING_DIR_HOST)/bin/sstrip
+ STRIP:=$(STAGING_DIR_HOST)/bin/sstrip $(call qstrip,$(CONFIG_SSTRIP_ARGS))
endif
endif
RSTRIP= \