aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-30 09:59:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-30 09:59:00 +0000
commitfff48825616d0ba34c9b00c100c55407091d42d9 (patch)
tree5c9866bb4198b3caf313447bee85433eaeead34d /package
parent6aa8c5de6450c76887dc639cb2b6c1db9a7e2a4b (diff)
downloadupstream-fff48825616d0ba34c9b00c100c55407091d42d9.tar.gz
upstream-fff48825616d0ba34c9b00c100c55407091d42d9.tar.bz2
upstream-fff48825616d0ba34c9b00c100c55407091d42d9.zip
fix madwifi hal target for mips*
SVN-Revision: 12435
Diffstat (limited to 'package')
-rw-r--r--package/madwifi/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 699a4afd0a..adfd418b20 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -54,11 +54,20 @@ ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
BUS:=
endif
-ifeq ($(ARCH),mips)
- HAL_TARGET:=mips-be-elf
-endif
-ifeq ($(ARCH),mipsel)
- HAL_TARGET:=mips-le-elf
+ifneq ($(CONFIG_CPU_MIPS32_R2),)
+ ifeq ($(ARCH),mips)
+ HAL_TARGET:=mips32r2-be-elf
+ endif
+ ifeq ($(ARCH),mipsel)
+ HAL_TARGET:=mips32r2-le-elf
+ endif
+else
+ ifeq ($(ARCH),mips)
+ HAL_TARGET:=mips32-be-elf
+ endif
+ ifeq ($(ARCH),mipsel)
+ HAL_TARGET:=mips32-le-elf
+ endif
endif
ifeq ($(ARCH),i386)
HAL_TARGET:=i386-elf