aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-28 10:39:19 +0100
committerMathias Kresin <dev@kresin.me>2018-01-09 22:06:55 +0100
commitf5df635ccf5162872044b2ade03f0879735e76fb (patch)
treec08be860204d7c2da46366b3eadd724788ee714b /package
parentc9e2c35f46346fc460a78b8f13b70d538c47cb27 (diff)
downloadupstream-f5df635ccf5162872044b2ade03f0879735e76fb.tar.gz
upstream-f5df635ccf5162872044b2ade03f0879735e76fb.tar.bz2
upstream-f5df635ccf5162872044b2ade03f0879735e76fb.zip
kirkwood: sync image filename with boardname
Use <manufacturer>_<modelname> as image name. Use the BOARD_NAME variable to ensure that the former used boardname is still used as the subdirectory name for the sysupgrade-tar image, to not break sysupgrade from earlier versions. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-kirkwood/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index aa143280d3..2b6f00f50f 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -17,53 +17,61 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=kirkwood
- BUILD_DEVICES:=$(patsubst %_second_stage,%,$(1))
endef
define U-Boot/dockstar
NAME:=Seagate DockStar
+ BUILD_DEVICES:=seagate_dockstar
endef
define U-Boot/dockstar_second_stage
NAME:=Seagate DockStar (second stage)
+ BUILD_DEVICES:=seagate_dockstar
endef
define U-Boot/goflexhome
NAME:=the Seagate GoFlexHome/GoFlexNet
- BUILD_DEVICES+=goflexnet
+ BUILD_DEVICES:=seagate_goflexhome seagate_goflexnet
endef
define U-Boot/ib62x0
NAME:=RaidSonic ICY BOX NAS6210 and NAS6220
+ BUILD_DEVICES:=raidsonic_ib-nas62x0
endef
define U-Boot/ib62x0_second_stage
NAME:=RaidSonic ICY BOX NAS6210 and NAS6220 (second stage)
+ BUILD_DEVICES:=raidsonic_ib-nas62x0
endef
define U-Boot/iconnect
NAME:=Iomega iConnect Wireless
+ BUILD_DEVICES:=iom_iconnect-1.1
endef
define U-Boot/iconnect_second_stage
NAME:=Iomega iConnect Wireless (second stage)
+ BUILD_DEVICES:=iom_iconnect-1.1
endef
define U-Boot/nsa310
NAME:=Zyxel NSA310
- BUILD_DEVICES:=nsa310b
+ BUILD_DEVICES:=zyxel_nsa310b
endef
define U-Boot/nsa325
NAME:=Zyxel NSA325v1 and v2
+ BUILD_DEVICES:=zyxel_nsa325
endef
define U-Boot/pogo_e02
NAME:=Cloud Engines Pogoplug E02
+ BUILD_DEVICES:=cloudengines_pogoe02
endef
define U-Boot/pogo_e02_second_stage
NAME:=Cloud Engines Pogoplug E02 (second stage)
+ BUILD_DEVICES:=cloudengines_pogoe02
endef
UBOOT_TARGETS := \