aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-07-24 09:02:55 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-08-01 14:54:39 +0100
commitf2af32c20c7529650858f6804e2bfd35fe706ced (patch)
tree6fd02419d3a5c6366fa8e301694df4e5636471e1 /package
parentcd41234d2f63c484eeec619e0fb82ae54fe8979e (diff)
downloadupstream-f2af32c20c7529650858f6804e2bfd35fe706ced.tar.gz
upstream-f2af32c20c7529650858f6804e2bfd35fe706ced.tar.bz2
upstream-f2af32c20c7529650858f6804e2bfd35fe706ced.zip
wireguard-tools: allow compiling with MIPS16 instructions
The wg utility compiles and runs without issues in MIPS16 mode, despite setting PKG_USE_MIPS16:=0 in the makefile. Let's remove this, allowing for a substantial size reduction of the wg executable. Since wg is a just a configuration utility, it shouldn't be performance-critical, as the crypto heavy-lifting is done on the kernel side. wg sizes for both modes: MIPS32: 64309 bytes MIPS16: 42501 bytes Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/wireguard-tools/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/network/utils/wireguard-tools/Makefile b/package/network/utils/wireguard-tools/Makefile
index 3232060bd1..2137a8b4a1 100644
--- a/package/network/utils/wireguard-tools/Makefile
+++ b/package/network/utils/wireguard-tools/Makefile
@@ -22,7 +22,6 @@ PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
PKG_BUILD_PARALLEL:=1
-PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/package-defaults.mk