aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-13 03:07:21 +0200
committerJo-Philipp Wich <jo@mein.io>2016-11-02 02:33:30 +0100
commiteb10b13f16bfebdbda5c473c55c0520b8992b6da (patch)
treedca276112476da828b70db440fe83e69ce137588 /package
parent7a5897268008a85c3843ae522b2b274911a9eec0 (diff)
downloadupstream-eb10b13f16bfebdbda5c473c55c0520b8992b6da.tar.gz
upstream-eb10b13f16bfebdbda5c473c55c0520b8992b6da.tar.bz2
upstream-eb10b13f16bfebdbda5c473c55c0520b8992b6da.zip
iproute2: rename ip to ip-tiny and let both ip-tiny and ip-full provide "ip"
Rename the "ip" package declaration to "ip-tiny" and let both "ip-tiny" and "ip-full" provide the virtual "ip" package. This allows users to freely choose the "ip" command variant while other packages can continue to depend on "ip" without needing to enforce a specific variant. Note that this commit does not add busybox as "ip" provider due to the following reasons: - The builtin Busybox ip applet cannot be added or removed at runtime - Both "ip-tiny" and "ip-full" are able to install without file clashes even if the busybox applet is enabled - The system is preferring full "ip-tiny" and "ip-full" at runtime, even if Busybox ip is still present. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iproute2/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 9575ff1056..ab38d0e6d3 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=4.4.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
@@ -30,14 +30,15 @@ define Package/iproute2/Default
MAINTAINER:=Russell Senior <russell@personaltelco.net>
DEPENDS:= +libnl-tiny
VARIANT:=$(1)
+ PROVIDES:=$(3)
endef
-define Package/ip
-$(call Package/iproute2/Default,tiny,Minimal)
+define Package/ip-tiny
+$(call Package/iproute2/Default,tiny,Minimal,ip)
CONFLICTS:=ip-full
endef
-Package/ip-full=$(call Package/iproute2/Default,full,Full)
+Package/ip-full:=$(call Package/iproute2/Default,full,Full,ip)
define Package/tc
$(call Package/iproute2/Default)
@@ -101,7 +102,7 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
endef
-define Package/ip/install
+define Package/ip-tiny/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/bin/
endef
@@ -138,7 +139,7 @@ define Package/nstat/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/nstat $(1)/usr/sbin/
endef
-$(eval $(call BuildPackage,ip))
+$(eval $(call BuildPackage,ip-tiny))
$(eval $(call BuildPackage,ip-full))
$(eval $(call BuildPackage,tc))
$(eval $(call BuildPackage,genl))