aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-12-09 11:20:49 -1000
committerPaul Spooren <mail@aparcar.org>2020-12-09 23:24:22 -1000
commite7e16667ffd9d4a9d8d925a19ee08d0d360ae755 (patch)
tree2696a55f5570a34fdb2e7f849f825ed400ed3bb9 /package
parentdd3464023f1836ef4fa417509830aaf5618b9ae9 (diff)
downloadupstream-e7e16667ffd9d4a9d8d925a19ee08d0d360ae755.tar.gz
upstream-e7e16667ffd9d4a9d8d925a19ee08d0d360ae755.tar.bz2
upstream-e7e16667ffd9d4a9d8d925a19ee08d0d360ae755.zip
iftop: remove package
The package has no reason to be in openwrt.git. Move it to packages.git. Signed-off-by: Paul Spooren <mail@aparcar.org> Acked-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iftop/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/package/network/utils/iftop/Makefile b/package/network/utils/iftop/Makefile
deleted file mode 100644
index 98fe15c8f5..0000000000
--- a/package/network/utils/iftop/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=iftop
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://code.blinkace.com/pdw/iftop.git
-PKG_SOURCE_DATE:=2018-10-03
-PKG_SOURCE_VERSION:=77901c8c53e01359d83b8090aacfe62214658183
-PKG_MIRROR_HASH:=219231541a437f5aecd497796be0202d337e13f141359a93595bf2cd8c5c5544
-PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_LICENSE:=GPL-2.0
-
-PKG_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/iftop
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=+libpcap +libncurses +libpthread
- TITLE:=display bandwith usage on an interface
- URL:=http://www.ex-parrot.com/~pdw/iftop/
-endef
-
-define Package/iftop/description
- iftop does for network usage what top(1) does for CPU usage. It
- listens to network traffic on a named interface and displays a
- table of current bandwidth usage by pairs of hosts. Handy for
- answering the question 'why is our ADSL link so slow?'.
-endef
-
-define Package/iftop/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/iftop $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,iftop))