aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-01-26 14:40:25 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-01-26 15:29:02 +0800
commite6de92cdcc31c68c56fa0c5b0c82ee4c56a95218 (patch)
tree934de4a71f66ac5532b1d8dee8c4d256b25d5f63 /package
parentdc555d003c21679c8c94ac7f5c74cbd5cd089ae0 (diff)
downloadupstream-e6de92cdcc31c68c56fa0c5b0c82ee4c56a95218.tar.gz
upstream-e6de92cdcc31c68c56fa0c5b0c82ee4c56a95218.tar.bz2
upstream-e6de92cdcc31c68c56fa0c5b0c82ee4c56a95218.zip
iptables: make kmod-ipt-debug part of default ALL build
The iptables TRACE target is only available in raw table that's why the dependency was moved from iptables-mod-trace into kmod-ipt-debug Fixes FS#1219 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netfilter.mk3
-rw-r--r--package/network/utils/iptables/Makefile4
2 files changed, 3 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index f458457500..097c0cab03 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -447,10 +447,9 @@ $(eval $(call KernelPackage,ipt-nfqueue))
define KernelPackage/ipt-debug
TITLE:=Module for debugging/development
KCONFIG:=$(KCONFIG_IPT_DEBUG)
- DEFAULT:=n
FILES:=$(foreach mod,$(IPT_DEBUG-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_DEBUG-m)))
- $(call AddDepends/ipt)
+ $(call AddDepends/ipt,+kmod-ipt-raw +IPV6:kmod-ipt-raw6)
endef
define KernelPackage/ipt-debug/description
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index e09c35c696..207676e290 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.netfilter.org/iptables
@@ -218,7 +218,7 @@ define Package/iptables-mod-nflog/description
endef
define Package/iptables-mod-trace
-$(call Package/iptables/Module, +kmod-ipt-debug +kmod-ipt-raw)
+$(call Package/iptables/Module, +kmod-ipt-debug)
TITLE:=Netfilter TRACE target
endef