aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-09 12:09:29 +0100
committerJo-Philipp Wich <jo@mein.io>2018-12-18 17:22:07 +0100
commite2637a471a647a99ce419177a2bd20dd7507ca80 (patch)
tree788dd869e7ed9abf8ec0eae348483ad570899b0a /package
parentc756d666dc044ca89e2da08ed569b61a69dd7cf4 (diff)
downloadupstream-e2637a471a647a99ce419177a2bd20dd7507ca80.tar.gz
upstream-e2637a471a647a99ce419177a2bd20dd7507ca80.tar.bz2
upstream-e2637a471a647a99ce419177a2bd20dd7507ca80.zip
Revert "iptables: fix dependency for libip6tc on IPV6"
This patch reverts commit 2dc1f54b1205094e7c6036cae6275d2c326bad3e as it breaks the build for me on x86-64 if I've IPV6 support disabled. Same config builds fine on `openwrt-18.06` branch at 55d078b2. $ grep IPV6 .config # CONFIG_KERNEL_IPV6 is not set # CONFIG_IPV6 is not set Build errors out on: Package libiptc is missing dependencies for the following libraries: libip6tc.so.0 Looking at iptables-1.6.2/libiptc/Makefile.am: libiptc_la_LIBADD = libip4tc.la libip6tc.la and to iptables-1.6.2/libiptc/libiptc.pc.in: Requires: libip4tc libip6tc It seems that libiptc needs v4/v6 libs, so v6 isn't optional. Cc: Rosy Song <rosysong@rosinson.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> (backported from 1b4b942bcef8638a040788ab9ae94c66e38fd960)
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index c1e4790d11..9c7179c51d 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -462,7 +462,7 @@ define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
+ DEPENDS:=+libip4tc +libip6tc +libxtables
ABI_VERSION:=$(PKG_VERSION)
TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
endef
@@ -482,7 +482,7 @@ $(call Package/iptables/Default)
CATEGORY:=Libraries
TITLE:=IPv6 firewall - shared libiptc library
ABI_VERSION:=$(PKG_VERSION)
- DEPENDS:=@IPV6 +libxtables
+ DEPENDS:=+libxtables
endef
define Package/libxtables