aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-28 13:45:06 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-28 13:45:06 +0000
commite25e6df2cf38de386cc5d06ec9b1e33ab3bce638 (patch)
tree9ddf86767d4a71d2898af2cb125e2a03dfa25949 /package
parent772a6645717bb881fab2941bb4f9ede04cfb56a7 (diff)
downloadupstream-e25e6df2cf38de386cc5d06ec9b1e33ab3bce638.tar.gz
upstream-e25e6df2cf38de386cc5d06ec9b1e33ab3bce638.tar.bz2
upstream-e25e6df2cf38de386cc5d06ec9b1e33ab3bce638.zip
linux: add upstream patch to allow building dwc2 as module on 3.18
Also add the required config symbols to usb.mk Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44181
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 3db70f8951..2499af1007 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -438,6 +438,8 @@ define KernelPackage/usb-dwc2
DEPENDS:=@!LINUX_3_8 @!LINUX_3_10
KCONFIG:= \
CONFIG_USB_DWC2 \
+ CONFIG_USB_DWC2_PCI \
+ CONFIG_USB_DWC2_PLATFORM \
CONFIG_USB_DWC2_DEBUG=n \
CONFIG_USB_DWC2_VERBOSE=n \
CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n