aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-24 15:47:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-24 15:47:15 +0000
commite1a654dd9f264d9747c7ea43e7bd35dd5955143a (patch)
treeceaf02ff156e81c90bca3a9ae402672c06976293 /package
parent766d2494b2116cf369a8206d6d6f310236235751 (diff)
downloadupstream-e1a654dd9f264d9747c7ea43e7bd35dd5955143a.tar.gz
upstream-e1a654dd9f264d9747c7ea43e7bd35dd5955143a.tar.bz2
upstream-e1a654dd9f264d9747c7ea43e7bd35dd5955143a.zip
base-files: unconditionally unlock the rootfs_data partition (#7437)
SVN-Revision: 22377
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/preinit/40_mount_jffs21
2 files changed, 2 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 24bbf188c3..137eb62a2f 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=50
+PKG_RELEASE:=51
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/preinit/40_mount_jffs2 b/package/base-files/files/lib/preinit/40_mount_jffs2
index cb743ea75c..d2f05b02ce 100644
--- a/package/base-files/files/lib/preinit/40_mount_jffs2
+++ b/package/base-files/files/lib/preinit/40_mount_jffs2
@@ -5,6 +5,7 @@
find_mount_jffs2() {
mkdir -p /tmp/overlay
mount "$(find_mtd_part rootfs_data)" /tmp/overlay -t jffs2
+ mtd -qq unlock rootfs_data
}
jffs2_not_mounted() {