aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-01-26 09:00:51 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-02-08 21:43:00 +0100
commitdea953744dff41794ccecbe7b0854ae99bdfe570 (patch)
treed12434f30466361e580820f8517e7f0aefd9c3bb /package
parent5e1a929bf2eef9e5018dfa1070102aa6725f4b13 (diff)
downloadupstream-dea953744dff41794ccecbe7b0854ae99bdfe570.tar.gz
upstream-dea953744dff41794ccecbe7b0854ae99bdfe570.tar.bz2
upstream-dea953744dff41794ccecbe7b0854ae99bdfe570.zip
ltq-adsl-app: use ubus to provide metrics
luci now uses ubus directly, so remove 'lucistat'. For manual usage just print the ubus output, use luci for a pretty version. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/config/ltq-adsl-app/Makefile2
-rw-r--r--package/network/config/ltq-adsl-app/files/dsl_control7
2 files changed, 5 insertions, 4 deletions
diff --git a/package/network/config/ltq-adsl-app/Makefile b/package/network/config/ltq-adsl-app/Makefile
index 0e8bacdbec..2e4792266c 100644
--- a/package/network/config/ltq-adsl-app/Makefile
+++ b/package/network/config/ltq-adsl-app/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=dsl_cpe_control_danube
PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
PKG_SOURCE_URL:=@OPENWRT
diff --git a/package/network/config/ltq-adsl-app/files/dsl_control b/package/network/config/ltq-adsl-app/files/dsl_control
index 49c342d9d5..4bd6e860e8 100644
--- a/package/network/config/ltq-adsl-app/files/dsl_control
+++ b/package/network/config/ltq-adsl-app/files/dsl_control
@@ -4,10 +4,11 @@
START=97
USE_PROCD=1
-extra_command "dslstat" "Get DSL status information"
-extra_command "lucistat" "Get status information in lua friendly format"
+dslstat() {
+ ubus call dsl metrics
+}
-. /lib/functions/lantiq_dsl.sh
+extra_command "dslstat" "Get DSL status information"
annex_b=10_00_10_00_00_04_00_00
annex_bdmt=10_00_00_00_00_00_00_00