aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-01-14 21:34:02 -0800
committerJohn Crispin <john@phrozen.org>2017-01-15 17:43:14 +0100
commitdea191914c1c331f517fcc202b24d86ccc84061e (patch)
treeeb959928de9390702ed087cddf10166f427640b4 /package
parentace9d1fb6fc43278a342b433bd4ce8329b4b233d (diff)
downloadupstream-dea191914c1c331f517fcc202b24d86ccc84061e.tar.gz
upstream-dea191914c1c331f517fcc202b24d86ccc84061e.tar.bz2
upstream-dea191914c1c331f517fcc202b24d86ccc84061e.zip
kernel: can: Add missing regmap dependency for kernel 4.4
Fixes build failure for kmod-can-c-can-platform which depends on kmod-regmap for kernel 4.1 and 4.4. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/can.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index eeef88a835..5529fe02e0 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -241,7 +241,7 @@ $(eval $(call KernelPackage,can-c-can))
define KernelPackage/can-c-can-platform
TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
- DEPENDS:=kmod-can-c-can +LINUX_4_1:kmod-regmap
+ DEPENDS:=kmod-can-c-can +!LINUX_3_18:kmod-regmap
FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
AUTOLOAD:=$(call AutoProbe,c_can_platform)
$(call AddDepends/can)