aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-10 10:22:19 +0200
committerJohn Crispin <john@phrozen.org>2018-05-10 10:22:19 +0200
commitdc629d9cf5afc03f67a294078ca1001e831c66c9 (patch)
treeb7d5046096cd9427450f5699c1eb1fd4afc64576 /package
parentce4d2fb5cc6ea4c2f12cf9b64a54199ef00ee168 (diff)
downloadupstream-dc629d9cf5afc03f67a294078ca1001e831c66c9.tar.gz
upstream-dc629d9cf5afc03f67a294078ca1001e831c66c9.tar.bz2
upstream-dc629d9cf5afc03f67a294078ca1001e831c66c9.zip
kernel: fix kmod-switch-rtl8366-smi dependency
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 23939b62bf..f5e6d3d6f0 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -209,7 +209,7 @@ $(eval $(call KernelPackage,switch-ip17xx))
define KernelPackage/switch-rtl8366-smi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek RTL8366 SMI switch interface support
- DEPENDS:=@GPIO_SUPPORT +kmod-swconfig
+ DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +CONFIG_OF:kmod-of-mdio
KCONFIG:=CONFIG_RTL8366_SMI
FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)