aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-06 19:15:59 -0700
committerHans Dedecker <dedeckeh@gmail.com>2020-04-07 20:40:03 +0200
commitd8bde3687a23742d1072be1a55f3b44ae29438ae (patch)
treeb7f85f23414befe370a466d05ac0fb28efe75e13 /package
parent92792ead34ba53d008e28b1421d72b490cb04703 (diff)
downloadupstream-d8bde3687a23742d1072be1a55f3b44ae29438ae.tar.gz
upstream-d8bde3687a23742d1072be1a55f3b44ae29438ae.tar.bz2
upstream-d8bde3687a23742d1072be1a55f3b44ae29438ae.zip
iproute2: add kmod-netlink-diag for ss
Allows proper usage of the ss tool. Otherwise, several errors and bad data gets thrown: Cannot open netlink socket: Protocol not supported Cannot open netlink socket: Protocol not supported Cannot open netlink socket: Protocol not supported Cannot open netlink socket: Protocol not supported Cannot open netlink socket: Protocol not supported Cannot open netlink socket: Protocol not supported Cannot open netlink socket: Protocol not supported Originally reported here: https://github.com/openwrt/packages/issues/8232 Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iproute2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index cff582283c..aa87a7af05 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=5.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
@@ -73,7 +73,7 @@ endef
define Package/ss
$(call Package/iproute2/Default)
TITLE:=Socket statistics utility
- DEPENDS:=+libnl-tiny +(PACKAGE_devlink||PACKAGE_rdma):libmnl +(PACKAGE_tc||PACKAGE_ip-full):libelf
+ DEPENDS:=+libnl-tiny +(PACKAGE_devlink||PACKAGE_rdma):libmnl +(PACKAGE_tc||PACKAGE_ip-full):libelf +kmod-netlink-diag
endef
define Package/nstat