aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 14:48:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 14:48:16 +0000
commitd4465bee36af3fec80666aa279ef869e4d771f5d (patch)
treef8eacdde86c4fb351287e9ebb49e2f2acb69007b /package
parentdbfeb5d1580f3fea00b3ced6291180ef95a922c0 (diff)
downloadupstream-d4465bee36af3fec80666aa279ef869e4d771f5d.tar.gz
upstream-d4465bee36af3fec80666aa279ef869e4d771f5d.tar.bz2
upstream-d4465bee36af3fec80666aa279ef869e4d771f5d.zip
openssl: fix syntax error in OpenWrt Makefile
SVN-Revision: 29774
Diffstat (limited to 'package')
-rw-r--r--package/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 48e8a427f6..67f643c92f 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -142,7 +142,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc)
+ [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc || true
endef
define Package/libopenssl/install