aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-03-20 13:19:22 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-21 22:16:31 +0100
commitd25d281fd6686bda67636f6c1df918145b6cb738 (patch)
tree1c7a189942fc169ddc25d4193bfb1ab8605139c7 /package
parent310b7f76e8dad4255efa7510c589b2c3f36af3f5 (diff)
downloadupstream-d25d281fd6686bda67636f6c1df918145b6cb738.tar.gz
upstream-d25d281fd6686bda67636f6c1df918145b6cb738.tar.bz2
upstream-d25d281fd6686bda67636f6c1df918145b6cb738.zip
uhttpd: Reload config after uhttpd-mod-ubus was added
Without this change the config is only committed, but the uhttpd daemon is not reloaded. This reload is needed to apply the config. Without the reload of uhttpd, the ubus server is not available over http and returns a Error 404. This caused problems when installing luci on the snapshots and accessing it without reloading uhttpd. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile2
-rw-r--r--package/network/services/uhttpd/files/ubus.default2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 796eb61298..28a817d2e0 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/uhttpd.git
diff --git a/package/network/services/uhttpd/files/ubus.default b/package/network/services/uhttpd/files/ubus.default
index ca9e72a315..b218d3f85d 100644
--- a/package/network/services/uhttpd/files/ubus.default
+++ b/package/network/services/uhttpd/files/ubus.default
@@ -3,11 +3,13 @@
if [ -z "$(uci -q get uhttpd.main.ubus_prefix)" ]; then
uci set uhttpd.main.ubus_prefix=/ubus
uci commit uhttpd
+ /etc/init.d/uhttpd reload
fi
[ "$(uci -q get uhttpd.main.ubus_socket)" = "/var/run/ubus.sock" ] && {
uci set uhttpd.main.ubus_socket='/var/run/ubus/ubus.sock'
uci commit uhttpd
+ /etc/init.d/uhttpd reload
}
exit 0