aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2017-02-10 16:18:47 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-15 11:28:57 +0100
commitd1a75c5161bbd1cdc148a8d8a5b0b71936dce08d (patch)
treef03c9e12ff5fb4dc215e34b55c58aadf02a6f5e1 /package
parent3bfcd21e4b4504b04b0ea2bffe8430864138db2a (diff)
downloadupstream-d1a75c5161bbd1cdc148a8d8a5b0b71936dce08d.tar.gz
upstream-d1a75c5161bbd1cdc148a8d8a5b0b71936dce08d.tar.bz2
upstream-d1a75c5161bbd1cdc148a8d8a5b0b71936dce08d.zip
ebtables: update to last commit
Refreshed patches Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/ebtables/Makefile12
-rw-r--r--package/network/utils/ebtables/patches/100-musl_fix.patch175
-rw-r--r--package/network/utils/ebtables/patches/200-fix-extension-init.patch8
3 files changed, 12 insertions, 183 deletions
diff --git a/package/network/utils/ebtables/Makefile b/package/network/utils/ebtables/Makefile
index 93bb23e5ab..da7b7416af 100644
--- a/package/network/utils/ebtables/Makefile
+++ b/package/network/utils/ebtables/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
-PKG_VERSION:=2.0.10-4
-PKG_RELEASE:=5
+PKG_SOURCE_DATE:=2015-10-28
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/ebtables
-PKG_HASH:=dc6f7b484f207dc712bfca81645f45120cb6aee3380e77a1771e9c34a9a4455d
+PKG_SOURCE_URL:=git://git.netfilter.org/ebtables
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=4c3e5cd3dbae3ea773e9dcca7cf019b2713af70d
+PKG_MIRROR_HASH:=997a877da02d6e2141e6d31c5d4dd005737facecfdbea07308c0e1286db8591c
-PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/utils/ebtables/patches/100-musl_fix.patch b/package/network/utils/ebtables/patches/100-musl_fix.patch
index 0ac1fbfecf..3fe5845897 100644
--- a/package/network/utils/ebtables/patches/100-musl_fix.patch
+++ b/package/network/utils/ebtables/patches/100-musl_fix.patch
@@ -1,181 +1,10 @@
---- a/extensions/ebt_among.c
-+++ b/extensions/ebt_among.c
-@@ -13,7 +13,6 @@
- #include <ctype.h>
- #include <unistd.h>
- #include "../include/ebtables_u.h"
--#include <netinet/ether.h>
- #include "../include/ethernetdb.h"
- #include <linux/if_ether.h>
- #include <linux/netfilter_bridge/ebt_among.h>
---- a/extensions/ebt_arpreply.c
-+++ b/extensions/ebt_arpreply.c
-@@ -12,7 +12,6 @@
- #include <string.h>
- #include <getopt.h>
- #include "../include/ebtables_u.h"
--#include <netinet/ether.h>
- #include <linux/netfilter_bridge/ebt_arpreply.h>
-
- static int mac_supplied;
---- a/extensions/ebt_nat.c
-+++ b/extensions/ebt_nat.c
-@@ -11,7 +11,6 @@
- #include <string.h>
- #include <getopt.h>
- #include "../include/ebtables_u.h"
--#include <netinet/ether.h>
- #include <linux/netfilter_bridge/ebt_nat.h>
-
- static int to_source_supplied, to_dest_supplied;
---- a/useful_functions.c
-+++ b/useful_functions.c
-@@ -25,7 +25,6 @@
- #include "include/ebtables_u.h"
- #include "include/ethernetdb.h"
- #include <stdio.h>
--#include <netinet/ether.h>
- #include <string.h>
- #include <stdlib.h>
- #include <getopt.h>
--- a/include/ebtables_u.h
+++ b/include/ebtables_u.h
-@@ -23,7 +23,9 @@
+@@ -23,6 +23,7 @@
#ifndef EBTABLES_U_H
#define EBTABLES_U_H
-+#include <sys/types.h>
++#define _NETINET_IF_ETHER_H
#include <netinet/in.h>
-+#include <netinet/ether.h>
#include <linux/netfilter_bridge/ebtables.h>
#include <linux/netfilter/x_tables.h>
-
---- a/include/linux/if_ether.h
-+++ /dev/null
-@@ -1,126 +0,0 @@
--/*
-- * INET An implementation of the TCP/IP protocol suite for the LINUX
-- * operating system. INET is implemented using the BSD Socket
-- * interface as the means of communication with the user level.
-- *
-- * Global definitions for the Ethernet IEEE 802.3 interface.
-- *
-- * Version: @(#)if_ether.h 1.0.1a 02/08/94
-- *
-- * Author: Fred N. van Kempen, <waltje@uWalt.NL.Mugnet.ORG>
-- * Donald Becker, <becker@super.org>
-- * Alan Cox, <alan@lxorguk.ukuu.org.uk>
-- * Steve Whitehouse, <gw7rrm@eeshack3.swan.ac.uk>
-- *
-- * This program is free software; you can redistribute it and/or
-- * modify it under the terms of the GNU General Public License
-- * as published by the Free Software Foundation; either version
-- * 2 of the License, or (at your option) any later version.
-- */
--
--#ifndef _LINUX_IF_ETHER_H
--#define _LINUX_IF_ETHER_H
--
--#include <linux/types.h>
--
--/*
-- * IEEE 802.3 Ethernet magic constants. The frame sizes omit the preamble
-- * and FCS/CRC (frame check sequence).
-- */
--
--#define ETH_ALEN 6 /* Octets in one ethernet addr */
--#define ETH_HLEN 14 /* Total octets in header. */
--#define ETH_ZLEN 60 /* Min. octets in frame sans FCS */
--#define ETH_DATA_LEN 1500 /* Max. octets in payload */
--#define ETH_FRAME_LEN 1514 /* Max. octets in frame sans FCS */
--#define ETH_FCS_LEN 4 /* Octets in the FCS */
--
--/*
-- * These are the defined Ethernet Protocol ID's.
-- */
--
--#define ETH_P_LOOP 0x0060 /* Ethernet Loopback packet */
--#define ETH_P_PUP 0x0200 /* Xerox PUP packet */
--#define ETH_P_PUPAT 0x0201 /* Xerox PUP Addr Trans packet */
--#define ETH_P_IP 0x0800 /* Internet Protocol packet */
--#define ETH_P_X25 0x0805 /* CCITT X.25 */
--#define ETH_P_ARP 0x0806 /* Address Resolution packet */
--#define ETH_P_BPQ 0x08FF /* G8BPQ AX.25 Ethernet Packet [ NOT AN OFFICIALLY REGISTERED ID ] */
--#define ETH_P_IEEEPUP 0x0a00 /* Xerox IEEE802.3 PUP packet */
--#define ETH_P_IEEEPUPAT 0x0a01 /* Xerox IEEE802.3 PUP Addr Trans packet */
--#define ETH_P_DEC 0x6000 /* DEC Assigned proto */
--#define ETH_P_DNA_DL 0x6001 /* DEC DNA Dump/Load */
--#define ETH_P_DNA_RC 0x6002 /* DEC DNA Remote Console */
--#define ETH_P_DNA_RT 0x6003 /* DEC DNA Routing */
--#define ETH_P_LAT 0x6004 /* DEC LAT */
--#define ETH_P_DIAG 0x6005 /* DEC Diagnostics */
--#define ETH_P_CUST 0x6006 /* DEC Customer use */
--#define ETH_P_SCA 0x6007 /* DEC Systems Comms Arch */
--#define ETH_P_TEB 0x6558 /* Trans Ether Bridging */
--#define ETH_P_RARP 0x8035 /* Reverse Addr Res packet */
--#define ETH_P_ATALK 0x809B /* Appletalk DDP */
--#define ETH_P_AARP 0x80F3 /* Appletalk AARP */
--#define ETH_P_8021Q 0x8100 /* 802.1Q VLAN Extended Header */
--#define ETH_P_IPX 0x8137 /* IPX over DIX */
--#define ETH_P_IPV6 0x86DD /* IPv6 over bluebook */
--#define ETH_P_PAUSE 0x8808 /* IEEE Pause frames. See 802.3 31B */
--#define ETH_P_SLOW 0x8809 /* Slow Protocol. See 802.3ad 43B */
--#define ETH_P_WCCP 0x883E /* Web-cache coordination protocol
-- * defined in draft-wilson-wrec-wccp-v2-00.txt */
--#define ETH_P_PPP_DISC 0x8863 /* PPPoE discovery messages */
--#define ETH_P_PPP_SES 0x8864 /* PPPoE session messages */
--#define ETH_P_MPLS_UC 0x8847 /* MPLS Unicast traffic */
--#define ETH_P_MPLS_MC 0x8848 /* MPLS Multicast traffic */
--#define ETH_P_ATMMPOA 0x884c /* MultiProtocol Over ATM */
--#define ETH_P_LINK_CTL 0x886c /* HPNA, wlan link local tunnel */
--#define ETH_P_ATMFATE 0x8884 /* Frame-based ATM Transport
-- * over Ethernet
-- */
--#define ETH_P_PAE 0x888E /* Port Access Entity (IEEE 802.1X) */
--#define ETH_P_AOE 0x88A2 /* ATA over Ethernet */
--#define ETH_P_TIPC 0x88CA /* TIPC */
--#define ETH_P_1588 0x88F7 /* IEEE 1588 Timesync */
--#define ETH_P_FCOE 0x8906 /* Fibre Channel over Ethernet */
--#define ETH_P_FIP 0x8914 /* FCoE Initialization Protocol */
--#define ETH_P_EDSA 0xDADA /* Ethertype DSA [ NOT AN OFFICIALLY REGISTERED ID ] */
--
--/*
-- * Non DIX types. Won't clash for 1500 types.
-- */
--
--#define ETH_P_802_3 0x0001 /* Dummy type for 802.3 frames */
--#define ETH_P_AX25 0x0002 /* Dummy protocol id for AX.25 */
--#define ETH_P_ALL 0x0003 /* Every packet (be careful!!!) */
--#define ETH_P_802_2 0x0004 /* 802.2 frames */
--#define ETH_P_SNAP 0x0005 /* Internal only */
--#define ETH_P_DDCMP 0x0006 /* DEC DDCMP: Internal only */
--#define ETH_P_WAN_PPP 0x0007 /* Dummy type for WAN PPP frames*/
--#define ETH_P_PPP_MP 0x0008 /* Dummy type for PPP MP frames */
--#define ETH_P_LOCALTALK 0x0009 /* Localtalk pseudo type */
--#define ETH_P_CAN 0x000C /* Controller Area Network */
--#define ETH_P_PPPTALK 0x0010 /* Dummy type for Atalk over PPP*/
--#define ETH_P_TR_802_2 0x0011 /* 802.2 frames */
--#define ETH_P_MOBITEX 0x0015 /* Mobitex (kaz@cafe.net) */
--#define ETH_P_CONTROL 0x0016 /* Card specific control frames */
--#define ETH_P_IRDA 0x0017 /* Linux-IrDA */
--#define ETH_P_ECONET 0x0018 /* Acorn Econet */
--#define ETH_P_HDLC 0x0019 /* HDLC frames */
--#define ETH_P_ARCNET 0x001A /* 1A for ArcNet :-) */
--#define ETH_P_DSA 0x001B /* Distributed Switch Arch. */
--#define ETH_P_TRAILER 0x001C /* Trailer switch tagging */
--#define ETH_P_PHONET 0x00F5 /* Nokia Phonet frames */
--#define ETH_P_IEEE802154 0x00F6 /* IEEE802.15.4 frame */
--#define ETH_P_CAIF 0x00F7 /* ST-Ericsson CAIF protocol */
--
--/*
-- * This is an Ethernet frame header.
-- */
--
--struct ethhdr {
-- unsigned char h_dest[ETH_ALEN]; /* destination eth addr */
-- unsigned char h_source[ETH_ALEN]; /* source ether addr */
-- __be16 h_proto; /* packet type ID field */
--} __attribute__((packed));
--
--
--#endif /* _LINUX_IF_ETHER_H */
diff --git a/package/network/utils/ebtables/patches/200-fix-extension-init.patch b/package/network/utils/ebtables/patches/200-fix-extension-init.patch
index 63d237708f..b77df159aa 100644
--- a/package/network/utils/ebtables/patches/200-fix-extension-init.patch
+++ b/package/network/utils/ebtables/patches/200-fix-extension-init.patch
@@ -29,7 +29,7 @@
}
--- a/extensions/ebt_among.c
+++ b/extensions/ebt_among.c
-@@ -490,7 +490,7 @@ static struct ebt_u_match among_match =
+@@ -491,7 +491,7 @@ static struct ebt_u_match among_match =
.extra_ops = opts,
};
@@ -51,7 +51,7 @@
}
--- a/extensions/ebt_arpreply.c
+++ b/extensions/ebt_arpreply.c
-@@ -132,7 +132,7 @@ static struct ebt_u_target arpreply_targ
+@@ -133,7 +133,7 @@ static struct ebt_u_target arpreply_targ
.extra_ops = opts,
};
@@ -73,7 +73,7 @@
}
--- a/extensions/ebt_ip6.c
+++ b/extensions/ebt_ip6.c
-@@ -556,7 +556,7 @@ static struct ebt_u_match ip6_match =
+@@ -560,7 +560,7 @@ static struct ebt_u_match ip6_match =
.extra_ops = opts,
};
@@ -128,7 +128,7 @@
}
--- a/extensions/ebt_nat.c
+++ b/extensions/ebt_nat.c
-@@ -230,7 +230,7 @@ static struct ebt_u_target dnat_target =
+@@ -231,7 +231,7 @@ static struct ebt_u_target dnat_target =
.extra_ops = opts_d,
};