aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorVincent Wiemann <vincent.wiemann@ironai.com>2019-08-05 01:42:45 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-08 21:33:34 +0200
commitccb4b96b8a4990178512c7a785f998a5e6f74cc3 (patch)
treefcde82655f562994dc18c761e264842fee0760ad /package
parentd3e832d6fda8a39e7ec262994f75dac67353dcae (diff)
downloadupstream-ccb4b96b8a4990178512c7a785f998a5e6f74cc3.tar.gz
upstream-ccb4b96b8a4990178512c7a785f998a5e6f74cc3.tar.bz2
upstream-ccb4b96b8a4990178512c7a785f998a5e6f74cc3.zip
comgt-ncm: add driver dependencies again
In the commit 623716dd4318 ("comgt-ncm: Fix NCM protocol") the dependencies to vendor NCM drivers were removed, because: > comgt-ncm should not depend on the USB-serial-related kernel modules, > as the cdc-wdm control device works without them. There is also no need > to depend on kmod-huawei-cdc-ncm, since other manufacturers (like > Ericsson and Samsung) which use other kernel modules should also be > supported. From a user-perspective this does not make sense, as installing comgt-ncm (or luci-proto-ncm) should install all needed dependencies for using such a device. Furthermore depending on kmod-huawei-cdc-ncm does not mean that Ericsson and Samsung devices can't be supported. By the way it seems that Ericsson and Samsung devices never used NCM, but act as serial modems. Thus this commit adds the dependencies again. Signed-off-by: Vincent Wiemann <vincent.wiemann@ironai.com> [fixed title capitalization, formatted commit message, renamed Sony-Ericsson to Ericsson] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/comgt/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 58466f498c..64296c9852 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -47,7 +47,7 @@ endef
define Package/comgt-ncm
$(call Package/comgt/Default)
TITLE+=NCM 3G/4G Support
- DEPENDS:=+comgt +wwan
+ DEPENDS:=+comgt +wwan +kmod-usb-serial-option +kmod-usb-net-huawei-cdc-ncm
endef
define Package/comgt/description