aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-05-23 14:00:43 +0000
committerNicolas Thill <nico@openwrt.org>2010-05-23 14:00:43 +0000
commitcbdb5208951530b3df70cc02c234bcdc573cdc09 (patch)
tree9ef234257eeaa2fd1c5e64e1caab6c9b27736039 /package
parent7800ac4e58a002f0e8816c6dcd7d2877eb845ca0 (diff)
downloadupstream-cbdb5208951530b3df70cc02c234bcdc573cdc09.tar.gz
upstream-cbdb5208951530b3df70cc02c234bcdc573cdc09.tar.bz2
upstream-cbdb5208951530b3df70cc02c234bcdc573cdc09.zip
package/busybox: add upstream hush patch, bump release number
SVN-Revision: 21545
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/patches/000-upstream-hush.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 60daf8d7d4..3a06ad0eac 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.16.1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/000-upstream-hush.patch b/package/busybox/patches/000-upstream-hush.patch
new file mode 100644
index 0000000000..1e038bf99f
--- /dev/null
+++ b/package/busybox/patches/000-upstream-hush.patch
@@ -0,0 +1,11 @@
+--- a/shell/hush.c
++++ b/shell/hush.c
+@@ -6944,7 +6944,7 @@ int hush_main(int argc, char **argv)
+ /* -c 'script' (no params): prevent empty $0 */
+ G.global_argv--; /* points to argv[i] of 'script' */
+ G.global_argv[0] = argv[0];
+- G.global_argc--;
++ G.global_argc++;
+ } /* else -c 'script' ARG0 [ARG1...]: $0 is ARG0 */
+ init_sigmasks();
+ parse_and_run_string(optarg);