aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-25 10:20:12 -0800
committerDavid Bauer <mail@david-bauer.net>2021-02-26 20:41:01 +0100
commitcbcddc9f318607881799e329b327a68c4e76d5cb (patch)
tree2d3fe3b15a5cb5f5e82501c584dfa7f578643330 /package
parent0b53d6f7fa8cc35cec5b22e1c64a2407fab6dfe3 (diff)
downloadupstream-cbcddc9f318607881799e329b327a68c4e76d5cb.tar.gz
upstream-cbcddc9f318607881799e329b327a68c4e76d5cb.tar.bz2
upstream-cbcddc9f318607881799e329b327a68c4e76d5cb.zip
wireguard-tools: depend on kmod-wireguard
To the vast majority of the users, wireguard-tools are not useful without the underlying kernel module. The cornercase of only generating keys and not using the secure tunnel is something that won't be done on an embedded OpenWrt system often. On the other hand, maintaining a separate meta-package only for this use case introduces extra complexity. WireGuard changes for Linux 5.10 remove the meta-package. So let's make wireguard-tools depend on kmod-wireguard to make WireGuard easier to use without having to install multiple packages. Fixes: ea980fb9 ("wireguard: bump to 20191226") Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/wireguard-tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/utils/wireguard-tools/Makefile b/package/network/utils/wireguard-tools/Makefile
index ee332c28ef..5f8da147c1 100644
--- a/package/network/utils/wireguard-tools/Makefile
+++ b/package/network/utils/wireguard-tools/Makefile
@@ -36,7 +36,10 @@ define Package/wireguard-tools
URL:=https://www.wireguard.com
MAINTAINER:=Jason A. Donenfeld <Jason@zx2c4.com>
TITLE:=WireGuard userspace control program (wg)
- DEPENDS:=+@BUSYBOX_CONFIG_IP +@BUSYBOX_CONFIG_FEATURE_IP_LINK
+ DEPENDS:= \
+ +@BUSYBOX_CONFIG_IP \
+ +@BUSYBOX_CONFIG_FEATURE_IP_LINK \
+ +kmod-wireguard
endef
define Package/wireguard-tools/description