aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-11-13 23:51:31 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-11-13 23:51:31 +0000
commitcb0c8da7c26ffbc361f70f4a343e4f82c0429669 (patch)
treee2e50203c4a8d33de76f0cb6cc59c7f116a087e4 /package
parent9d6a9b6f516e650630d94012cb7e898df5301189 (diff)
downloadupstream-cb0c8da7c26ffbc361f70f4a343e4f82c0429669.tar.gz
upstream-cb0c8da7c26ffbc361f70f4a343e4f82c0429669.tar.bz2
upstream-cb0c8da7c26ffbc361f70f4a343e4f82c0429669.zip
kernel: take bcm47xx_nvram.h from kernel and not backports
compat-wireless/backports now contains a bcm47xx_nvram.h file to backport some of the functions in it which are used by the bcmfmac driver. This file just checks for the kernel versions and provide an empty implementations on older kernel versions. This is OK on most systems, but on bcm47xx / bcm53xx systems we want to call the real functions here. This commit removes the file from backports in our build process like we do it with the bcma and ssb header files. Instead we add a recent version into our kernel so all code uses only one header file. On bcm47xx / bcm53xx the real implementations of this code will be used. Reported-by: Hante Meuleman <meuleman@broadcom.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47467
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 580b2c3b6f..f2427de2f4 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1782,7 +1782,8 @@ define Build/Prepare
$(PKG_BUILD_DIR)/include/linux/eeprom_93cx6.h \
$(PKG_BUILD_DIR)/include/linux/wl12xx.h \
$(PKG_BUILD_DIR)/include/linux/spi/libertas_spi.h \
- $(PKG_BUILD_DIR)/include/net/ieee80211.h
+ $(PKG_BUILD_DIR)/include/net/ieee80211.h \
+ $(PKG_BUILD_DIR)/backport-include/linux/bcm47xx_nvram.h
echo 'compat-wireless-$(PKG_VERSION)-$(PKG_RELEASE)-$(REVISION)' > $(PKG_BUILD_DIR)/compat_version
$(CP) ./files/regdb.txt $(PKG_BUILD_DIR)/net/wireless/db.txt