aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2016-10-18 09:56:19 +0100
committerJohn Crispin <john@phrozen.org>2017-02-26 08:41:08 +0100
commitc8ac9c09f99a6f5c0ef1143551edee83b15d3657 (patch)
treed25830dc3758349472f0ae5eea1abaeccdea2b91 /package
parent699eedace08b54b0bb4592b88573314604c4c0f6 (diff)
downloadupstream-c8ac9c09f99a6f5c0ef1143551edee83b15d3657.tar.gz
upstream-c8ac9c09f99a6f5c0ef1143551edee83b15d3657.tar.bz2
upstream-c8ac9c09f99a6f5c0ef1143551edee83b15d3657.zip
iftop: bump to latest upstream
Drops a LEDE carried patch now upstream. Convert to autotools. A number of nits fixed upstream (dns & short packet handling most notable) Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iftop/Makefile14
-rw-r--r--package/network/utils/iftop/patches/110-fix-mac-display.patch67
2 files changed, 8 insertions, 73 deletions
diff --git a/package/network/utils/iftop/Makefile b/package/network/utils/iftop/Makefile
index 5bbee31fd7..8c5b47444f 100644
--- a/package/network/utils/iftop/Makefile
+++ b/package/network/utils/iftop/Makefile
@@ -8,16 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iftop
-PKG_VERSION:=1.0pre4
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
-PKG_HASH:=f733eeea371a7577f8fe353d86dd88d16f5b2a2e702bd96f5ffb2c197d9b4f97
+PKG_RELEASE:=1
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://code.blinkace.com/pdw/iftop.git
+PKG_SOURCE_DATE:=2017-02-06
+PKG_SOURCE_VERSION:=35af3cf65f17961d173b31fd3b00166ec095c226
+PKG_MIRROR_HASH:=84131e2448ea5aa884d2bd7d58dc81741b5c476b4664a8c2c1eb34f62985804a
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0
+PKG_FIXUP:=autoreconf
+
include $(INCLUDE_DIR)/package.mk
define Package/iftop
diff --git a/package/network/utils/iftop/patches/110-fix-mac-display.patch b/package/network/utils/iftop/patches/110-fix-mac-display.patch
deleted file mode 100644
index 5db53aaa52..0000000000
--- a/package/network/utils/iftop/patches/110-fix-mac-display.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-iftop: fix mac address display
-
-iftop would display portions of mac address with large ffffff prefixes.
-Make if_hw_addr type consistent.
-
-Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
----
- addrs_dlpi.c | 2 +-
- addrs_ioctl.c | 2 +-
- addrs_ioctl.h | 2 +-
- iftop.c | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/addrs_dlpi.c b/addrs_dlpi.c
-index 188fef8..6c04ea1 100644
---- a/addrs_dlpi.c
-+++ b/addrs_dlpi.c
-@@ -50,7 +50,7 @@ extern char *strncat2(char *dest, char *src, int n);
- */
-
- int
--get_addrs_dlpi(char *interface, char if_hw_addr[], struct in_addr *if_ip_addr)
-+get_addrs_dlpi(char *interface, u_int8_t if_hw_addr[], struct in_addr *if_ip_addr)
- {
- int got_hw_addr = 0;
- int got_ip_addr = 0;
-diff --git a/addrs_ioctl.c b/addrs_ioctl.c
-index 870c83b..7d01fb2 100644
---- a/addrs_ioctl.c
-+++ b/addrs_ioctl.c
-@@ -45,7 +45,7 @@
- */
-
- int
--get_addrs_ioctl(char *interface, char if_hw_addr[], struct in_addr *if_ip_addr, struct in6_addr *if_ip6_addr)
-+get_addrs_ioctl(char *interface, u_int8_t if_hw_addr[], struct in_addr *if_ip_addr, struct in6_addr *if_ip6_addr)
- {
- int s;
- struct ifreq ifr = {};
-diff --git a/addrs_ioctl.h b/addrs_ioctl.h
-index f93a0b4..739de61 100644
---- a/addrs_ioctl.h
-+++ b/addrs_ioctl.h
-@@ -7,6 +7,6 @@
- #define __ADDRS_IOCTL_H_
-
- int
--get_addrs_ioctl(char *interface, char if_hw_addr[], struct in_addr *if_ip_addr, struct in6_addr *if_ip6_addr);
-+get_addrs_ioctl(char *interface, u_int8_t if_hw_addr[], struct in_addr *if_ip_addr, struct in6_addr *if_ip6_addr);
-
- #endif /* __ADDRS_IOCTL_H_ */
-diff --git a/iftop.c b/iftop.c
-index a090dcf..f1b371a 100644
---- a/iftop.c
-+++ b/iftop.c
-@@ -55,7 +55,7 @@
-
- /* ethernet address of interface. */
- int have_hw_addr = 0;
--char if_hw_addr[6];
-+u_int8_t if_hw_addr[6];
-
- /* IP address of interface */
- int have_ip_addr = 0;
---
-1.9.1
-