aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 21:16:21 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 21:16:21 +0000
commitc3b763ac77108f3a98fc71ce8fcd52a512cb5b6e (patch)
tree4d5e268547b2c9e24b1e53306b9909cf7a591b41 /package
parentd65c6fe720c33dd05bd609d0c8570e3b4103d561 (diff)
downloadupstream-c3b763ac77108f3a98fc71ce8fcd52a512cb5b6e.tar.gz
upstream-c3b763ac77108f3a98fc71ce8fcd52a512cb5b6e.tar.bz2
upstream-c3b763ac77108f3a98fc71ce8fcd52a512cb5b6e.zip
package/kernel: add package for the PCF2123 RTC driver
SVN-Revision: 29664
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 266aa01cb8..62bc4e8a0d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -765,6 +765,22 @@ endef
$(eval $(call KernelPackage,rtc-pcf8563))
+define KernelPackage/rtc-pcf2123
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Philips PCF2123 RTC support
+ DEPENDS:=+kmod-rtc-core
+ KCONFIG:=CONFIG_RTC_DRV_PCF2123
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
+ AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)
+endef
+
+define KernelPackage/rtc-pcf2123/description
+ Kernel module for Philips PCF2123 RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pcf2123))
+
+
define KernelPackage/n810bm
SUBMENU:=$(OTHER_MENU)
TITLE:=Nokia N810 battery management driver